IT SOLUTIONS
Your full service technology partner! 
-Collapse +Expand
Paradox
Search Paradox Group:

Advanced
-Collapse +Expand Paradox To/From
To/FromCODEGuides
-Collapse +Expand Paradox Store
PRESTWOODSTORE

Prestwood eMagazine

May Edition
Subscribe now! It's Free!
Enter your email:

   ► MB LobbyCorel Paradox / ObjectPAL Coding Board   Print This     

Paradox Reports Topic Oldest Threads

 Show:
New Activity New Threads Oldest Unanswered Most Active Most Read
  


25 Threads:

Add New ThreadRandom Thread

Thread 25 of 25
Thread Starter  

seamud
Printing
We're using P9, Win98 machine with lots of power and RAM; printing to a new high-speed, high-memory printer. At 118 pages the printing corrupts. Never had the problem before. Changes to our system: upgraded server from Netware 4.x to Netware 5.x; now have DSL to client via network cable. Disconnected client from server: printing problem still persists. Why?
19 years ago
1 Reply:

badzooka
Are you still having this problem? Have you applied the P9 patches?
18 years ago
Nothing New Since Your Last Visit
2311
Hits

Thread 24 of 25
Thread Starter  

John Pickard
Problem printing images in reports Paradox 8
I have been trying to print a report from Paradox 8 and I cannot get a linked BMP to print properly. I have checked "best fit" in the Magnification section of Properties, and the report looks fine on screen. The images all come down to best fit with no problem. But when I try to print the report, the images all revert to their original sizes (which effectively means that I have lost them from the report.), , I have tried everything that seems logical (to me at least), but all to no avail. I have tried it with both a PS and non-PS printers, but it made no difference., , Any suggestions? I am sure that I can't be the only person who has had this problem, and I am equally sure that there is some really obvious way to fix it, but I just can't find it.
15 years ago
3 replies. Last post:

Tony.M80
Have you thought about resizing them to what the report needs?, , A copy, likely., , It'd be faster and cheaper to create a copy of each that is sized such that it fits the reports than to convert to a new application., , I do that for my app, and it works beautifically.
15 years ago
Nothing New Since Your Last Visit
2029
Hits

Thread 23 of 25
Thread Starter  

Greg MacKenzie
COUNT TOTAL BASED ON DATA IN REPORT
I am trying to create a report to track employee performance. The report is a summary report grouped by employee name. I am trying to track policy violations. To do this I have a data field that will have either a "Y" or an "N" in it. On the report I want to place a calculated field that will count the total instances the data field contains a "Y" for each employee. If there are no records for a particular employee containing a "Y" I want the calculation to return a 0 in the report. Is there a formula I can use to place this in the report. I am using Paradox Version 11.0., Thanks
15 years ago
2 replies. Last post:

SUBROMAN
Perfect!, , Thanks for your help Montana!
15 years ago
Nothing New Since Your Last Visit
2162
Hits

Thread 22 of 25
Thread Starter  

since92
Top 25 Customers Report
I am writing a routine in objectpal to get the top 25 customers into a table and subsequently a report. I can sort the table using "custTbl.attach" and "sort descending" like:, , custTbl.attach("sortme.db"), sort custTbl, on ":PRIV:revenue" D , to ":PRIV:sorted.db", endSort, , But I need some form of TCursor loop or similar method to peel off the first (top) 25 customers., , I could not find a 'Top n' feature in Paradox Reports, Currently using Paradox 11 with sp2. , Any assistance or links to a solution appreciated.
15 years ago
6 replies. Last post:

pszabo
tried:, darr["revenue"] = "not blank, >=" +string(rev) , But it returned the whole table :-( I guess "not blank" does not work the same as in queries in this instance., Overall though the primary objective has been achieved, thanks once again.
15 years ago
Nothing New Since Your Last Visit
2569
Hits

Thread 21 of 25
Thread Starter  

ntorres
Pdox 11 printing Dilema
We are upgrading to V 11.0.0411 from v 8 and in my testing of our apps I find that the selected printer that the preprinted forms are on defaults to LETTER paper size, even though i have coded it to setprinteroptions to LEGAL, i have seen the code make the changes but the final print is still in LETTER. What am i missing? There was a similar posting on this subject, but no real solution was given. I'm running XP pro Sp2. this is kind of urgent, just let me know where or what i need to tweak., thanks, Nestor
15 years ago
6 replies. Last post:

ntorres
the space in -> PtrInfo ["PaperSize"] = prnLegal was my bad in transfering the code. I have a test machine down the hall and a sneaker net in between. It won't come onLine until it's ready to hit the ground running. this print dilema is the hold up., , Nestor
15 years ago
Nothing New Since Your Last Visit
2358
Hits

Thread 20 of 25
Thread Starter  

Kelpy
Paradox 10/11 Printing conflict?
I have been using Paradox 10 without too many problems for quite a while but recently installed Paradox 11 (full Wordperfect Office 11 suite) plus all service packs., , Now I am unable to print any reports from Paradox 10. Pdox 10 stops responding, the menu bar and open windows go blank and I need to stop the app through the task Manager. No problems printing from 11 but it won't open delivered reports compiled in 10., , Has anyone else experienced this problem?, Does anyone know a solution to this problem?, Should I uninstal version 11 and stay with 10?
14 years ago
2 replies. Last post:

stevecaple
I haven't run into this because I don't have - and don't intend to have - Paradox 10^h^h11. (just a little WordStar joke there) Seriously, Corel hasn't really done much of anything, if anything really, since version 10 that I can't live without. I know a lot of folks running business appllications using versions 8 or 9 under Win-XP. Me, I'd stay with 10.
14 years ago
Nothing New Since Your Last Visit
3033
Hits

Thread 19 of 25
Thread Starter  

Jon
PDF Printing
I am having trouble printing to a PDF driver unless I go out of paradox - change my default printer to the PDF Writer and then go back in. If I change the printer from the Print Dialoge box the PDF file is all messed up., , I can change the printer through code in the full Paradox version - but when this same code is run on a Runtime version - I get the same jumbled results. Any ideas?, , Using P9 with sp3 on runtime and full, Adobe Acrobat 5.0
15 years ago
13 replies. Last post:

Moet
Montana,, , Have sorted the problem. We had to repeatedly call the findfirst function and check size was greater than zero before continuing. Paradox was creating an 'empty' PDF with the filename instantaneously but took a bit longer to populate it with data, , Jon
13 years ago
Nothing New Since Your Last Visit
5078
Hits

Thread 18 of 25
Thread Starter  

Paul Castelow
.rdl Scripts
In 9 Runtime when I try to run the report I am getting a message saying "ObjecPal not able to be executed on this version - go back to the source" or some such.. Has anybody else had that problem?
15 years ago
2 replies. Last post:

Dan
In some cases, I have seen a calculated field on a report cause something like this.  This was generally caused when the data table was modified resulting in the calculation becomming invalid.  Usually the calculated field will popup in an edit window and you can modify it or delete the calculation.
13 years ago
Nothing New Since Your Last Visit
1618
Hits

Thread 17 of 25
Thread Starter  

FlaglerMuseum
Sorting Report Groups
I have a question regarding the sorting of Groups in a report.  I know how to sort the band by going to Band Properties but the only options are ascending and descending.  Is it possible to create a personalized sort?  For example I want my groups to be: Foundation Contributions, Corporate Contributions and Individual Contributions and the contributors would fall under each group.  I need my report to list the Foundation Contributors first however since C comes before F the Corporate Contributors come up first.  Is there any workaround? Thanks,  Teresa
13 years ago
2 replies. Last post:

FlaglerMuseum
Thanks, That's exactly what I was doing but was hoping there was an easier way.
13 years ago
Nothing New Since Your Last Visit
2244
Hits

Thread 16 of 25
Thread Starter  

FlaglerMuseum
Report vs Form size
I'm having a bit of an issue with the window size of my reports and forms.  I want my forms to remain at the full size of the screen.  Under Form Data Properties I have checked off size to fit, I have several forms and when I open them they remain at full screen. The problem is that when I run reports they always come up a smaller screen size eventhough I have size to fit checked off under properties.  This wouldn't be much of a problem except for the fact that whenever I do open up a report not only does it shrink the report size but it shrinks the size of all the open forms, then after I close the report I have to maximize all my forms again.  This is driving me nuts as I run reports all day long.  Any suggestions? Thanks,  Teresa
13 years ago
1 Reply:

mprestwood
He Teresa, You can do this by opening the report hidden, maximize it, then show it.
13 years ago
Nothing New Since Your Last Visit
2264
Hits

Thread 15 of 25
Thread Starter  

Shawn.R
Insert image in report?
Pdox 10 -   I'm trying to copy and paste a bitmap image into a report and I get -  "Unexpected General Protection Violation" when i run the report in RT everytime..... Any tips on inserting an image into a report and tweaking it to fit right? Pdox seems pretty flaky when adjusting the bitmap image.... Thx, Shawn 
12 years ago
1 Reply:

Dan
I would suspect that the image you are attempting to insert is probably very large.  How exactly are you cuting and pastling the image to your report?  What service packs have you installed?  There has not been a whole lot of changes to the graphic object used to contain images on Paradox reports but bitmap images have increased significantly.
12 years ago
Nothing New Since Your Last Visit
2788
Hits

Thread 14 of 25
Thread Starter  

vinylsol
Reports from laptops cause a hang when printed
I have Paradox running on an Acer desktop and when I print reports they come out looking all lovely, just as you would expect. But I also used to have Sony Vaio laptop and when I tried printing the same reports from an exact duplicate of the table, to the same printer, Paradox would hang (the report went blank with the Windows egg-timer appearing but staying forever). I eventually moved from the Vaio and now have an Acer laptop and the same thing happens, but not every time. Whereas on the desktop everything is fine. Am I alone in encountering this?
13 years ago
13 replies. Last post:

vinylsol
{Too Long!}
12 years ago
Nothing New Since Your Last Visit
6622
Hits

Thread 13 of 25
Thread Starter  

AgCEagle
Printer Setup PD 5.0 on Windows XP
{Too Long!}
12 years ago
1 Reply:

mprestwood
{Too Long!}
12 years ago
Nothing New Since Your Last Visit
3259
Hits

Thread 12 of 25
Thread Starter  

Cfolkes
Page Layout for form
I am using Paradox 7 - 32 bit on a stand alone XP-Pro computer. When I try to create a new form and try to use "Form/Page Layout" I get an "Unexpected General Protect Violation".  I have done a clean re-install of Pdox and it did not fix the problem. Am I going bonkers?   I can't make custom forms without copying an old form and re-designing it to the new layout? 
12 years ago
2 replies. Last post:

CFOLKES
{Too Long!}
12 years ago
Nothing New Since Your Last Visit
2924
Hits

Thread 11 of 25
Thread Starter  

Peter Dissing
Barcode only works with asterisk
Hi We want to bring our order-number as a barcode on paper. The number is an Integer in the field. For this we use a Code 39 font, and the barcode looks all right on paper, but can not be read by the scanner. Only if we change the field to Alpha and put in * as start and stop character it works. Any idea how to aviod the asterisk, and anyone who knows a font where it works 'out of the box' ? Can the setup for scanner be changed  ? Using PDX11. Best regards Peter
11 years ago
4 replies. Last post:

larry_rutledge
{Too Long!}
11 years ago
Nothing New Since Your Last Visit
27260
Hits

Thread 10 of 25
Thread Starter  

Paul Castelow
Suppressing a field
Using a group band, I have several records resulting. I wish to show only a field in the first record, and suppress the same field in the following 3 or 4 records - because they are identical and surplus to requirements. How do I do this ? Thanks, Paul
11 years ago
2 replies. Last post:

1311
I think i'll use the record band meathod Al, many thanks.
11 years ago
Nothing New Since Your Last Visit
2690
Hits

Thread 9 of 25
Thread Starter  

Shellbot
Report Printing 2 duplicate rows
{Too Long!}
11 years ago
1 Reply:

shellbus
Was the formatting. The top part of the report was taking too much space..rearranged it all and took out as much white space as could at the end of it and that fixed the duplicate record coming out. Must be the way it reads the data or something? Shell
11 years ago
Nothing New Since Your Last Visit
3829
Hits

Thread 8 of 25
Thread Starter  

tsensor
fields in reports change on their own
I recently changed one of my computers. It is an HP running XP.  We have been running a particular paradox database for years and started using it on this new computer.  When I go to run a report as soon as I open it paradox changes some of the fields to a date field or sometimes another field.  I go back change the form, save it, it may work one or two times then I might change a filter and presto fields change on their own.  If I run the program on another computer it does not happen.  I have uninstalled paradox twice as well as wordperfect.  even reinstalled word perfect x3 and then upgraded to x4 to see if that had an affect to no avail. I am stumped.  Anyone have any suggestions?
11 years ago
Nothing New Since Your Last Visit
2829
Hits

Thread 7 of 25
Thread Starter  

ASPT
Form feed problems
Hello FYI, do not write  a note then run the spell check, then down load the spell checker.  You may well lose your note in the interim. My problem in a nut shell is that no matter what I try and what I do I can not get a PDOX 10 report form from overwriting the printer settings. I am trying to print a 4x6 track feed post card.  Paradox has a 4x6 template and Okidate Microline 186 has a method of changing page lengths ergo form feeds.  I change the form length on the printer and on a fresh start the buffer is clear and when I push the form feed button, the paper is advanced 4".  When I go to print the first record prints and then there is an 11" form feed. I can not find a custom form set up in the Oki driver and the set up in Pdox does not work either.  Any suggestions or anything I may not have thought of would be greatly appreciated. Thanks Ralph Maxwell  
11 years ago
1 Reply:

ric_shumack
Hi, Have you tried defining a custom form via the Print Server?  Open the Printers dialog in Windoze - then go to the menu option File--> Server Properties, and you should be able to add a custom form with your form length. Ric
11 years ago
Nothing New Since Your Last Visit
4765
Hits

Thread 6 of 25
Thread Starter  

KevinHart
Any Print closes Paradox
When trying to print anything (report, screen print, etc) from Paradox the printer dialog does not show and Paradox immediately shuts down with no error message. (Pdox 11 full, Windows 2000), Printing works fine with Wordperfect 11.
15 years ago
2 replies. Last post:

mprestwood
Also, I've had great luck deleting and reinstalling the printer drivers. Seems to clear things out. That's the first thing I try.
10 years ago
Nothing New Since Your Last Visit
2530
Hits

Thread 5 of 25
Thread Starter  

OzPaul
First page of report printed for day is garbage
Hi all, One of my Paradox 9 runtime (Windows XP) users has recently , started having a problem printing on our hospital network. Each day , the first page printed of a single page Paradox report is blown way , oversize so only a small amount appears on the page and two pages of , rubbish print. If she prints again, no problem. This seemed to begin , at the time I re-designed the print control to include a small dialog , form allowing her to choose which of her printers to use. It also , coincided with the introduction of a new printer. We have not done , extensive troubleshooting but another user has not complained and she , is sharing the same printer and has the same software application , installed. I don't think it should be a Paradox problem but I am , wondering if anyone has encountered this? Regards, Paul. ,
11 years ago
2 replies. Last post:

OzPaul
Hi Mike, I have been on leave so I checked with the user who has been having this problem and it seems to have mysteriously resolved itself. So no, I have not solved the puzzle but currently all is well. Thanks for your concern. Paul.
10 years ago
Nothing New Since Your Last Visit
3642
Hits

Thread 4 of 25
Thread Starter  

jglumb
blank in calculated field
Is it possible to check for a null (blank) value from within a calculated field. I currently have a calculated field using an iif statement that checks to see if the value of the field is 0 then it returns a string on the report. I would like to also check if the field is blank and return a different string on the report. 
10 years ago
1 Reply:

AIBreveleri
1. Turn off "Treat Blanks as Zeros".  Interactively, pick Edit | Preferences | Database and uncheck "Treat blank fields as zeros".  In code, use session.blankAsZero(false), 2. Use this model for your statement., iif(isblank(TT.FF]),"this field is blank",iif([TT.FF]=0,"this field is zero","this field contains "+string([TT.FF]))) -Al.
10 years ago
Nothing New Since Your Last Visit
2604
Hits

Thread 3 of 25
Thread Starter  

Jon
Printing forms as reports doesnt get all pages
I have a 3 page form that I need to open as a report.  When I open it, however, I only get the first page and a half.  Any ideas?  I have to do it this way because the form has some fields that are checkboxes and i need all the possible choices to print on the report.
10 years ago
1 Reply:

jondm
Figured it out - has to do with the page size - ended up having to create 3 seperate reports but it works.
10 years ago
Nothing New Since Your Last Visit
2426
Hits

Thread 2 of 25
Thread Starter  

kevin_baker
#Record is too big to fit in report Error
In Paradox for Windows, I'm getting this when trying to print a report. #Record is too big to fit in report.
9 years ago
1 Reply:

mprestwood
Sounds like a reports properties problem. Does your report have a TableFrame? If so, is the TableFrame breakable property checked or unchecked? What about Show All Records? Try changing the settings for the Breakable and ShowAllRecords properties.
9 years ago
Nothing New Since Your Last Visit
2710
Hits

Thread 1 of 25
Thread Starter  

Shores
changing non master table in report data model
{Too Long!}
9 years ago
2 replies. Last post:

Dan
{Too Long!}
9 years ago
Nothing New Since Your Last Visit
3182
Hits

New Thread
Go ahead!   Use Us! Call: 916-726-5675  Or visit our new sales site: 
www.prestwood.com


©1995-2020 Prestwood IT Solutions.   [Security & Privacy]