IT SOLUTIONS
Your full service technology partner! 
-Collapse +Expand
Paradox
Search Paradox Group:

Advanced
-Collapse +Expand Paradox To/From
To/FromCODEGuides
-Collapse +Expand Paradox Store
PRESTWOODSTORE

Prestwood eMagazine

May Edition
Subscribe now! It's Free!
Enter your email:

   ► MB LobbyCorel Paradox / ObjectPAL Coding BoardParadox Reports Topic   Print This     

Windows 7 Paradox 9 report crash

Windows 7 Paradox 9 report crash in Paradox Reports topic (part of our Corel Paradox / ObjectPAL Coding group).

Quick Search: Windows   Paradox   Windows 7   Windows 7 Paradox   9 report  
andwye
Wellington, -- UK

I've successfully installed Paradox 9 on a windows 7 workstation linked to SBS 2008.

However, when I went to amend a report by redefining a field, Paradox crashed. I've tried to do this on two different reports and on two different machines.

Why would this happen?

Does anyone know how to solve the problem?

 Posted 10 years ago (Thread Starter)
Comment Quote
About andwye -Collapse +Expand
Visit Profile
Approved member.
Member subscribes to this thread with a verified email.

Post ID #14228, 10 reply
Thread Started 7/13/2010 8:15:05 AM
View Counter=6761
Last Reply Posted 11/9/2015 5:13:05 AM)
Location=Wellington, -- UK 
Joined=13 years ago   MB Posts=11  
Anonymous Post

do you have the Paradox 9 service packs installed?

---
Samantha B
 Posted 10 years ago
Comment Quote

Post ID #14229 (Level 1.1)  Reply to 14228
Thread Started 7/13/2010 2:47:59 PM
Anonymous Post

My mistake. Relatively simple solution. I must remember to do a complete install rather than a compact install. The writing tools were missing.

---
andwye
 Posted 10 years ago
Comment Quote

Post ID #14230 (Level 2.1)  Reply to 14229 and Parent is 14228
Thread Started 7/14/2010 1:20:57 AM
andwye
Wellington, -- UK

I thought I'd solved the problem by installing the writing tools. However, the problem has reappeared today when I tried to amend an existing report. Each time I try to change a calculated field Paradox crashes.

I've reloaded Paradox 9 as well as SP3 and SP3_2. I've also loaded BDE 5.2. I've changed the Register and added DWord entries for LanManWorkstation and LanManServer. I've also created a new file in mrxsmb to DisableOplocks. Some of this may be unnecessary but I'm trying everything at the moment. I've even Disabled caching on the C drive.  Oh, I forgot, I've installed Netbui network protocol on the workstation. 

Could this me an antivirus issue?

What about the unused printer problems mentioned a few years ago? Windows 7 loads 3 printers that I suspect are generic but unused.

 Posted 10 years ago (Thread Starter)
Comment Quote
About andwye -Collapse +Expand
Visit Profile
Approved member.
Member subscribes to this thread with a verified email.

Post ID #14231 (Level 3.1)  Reply to 14230 and Parent is 14228
Thread Started 7/14/2010 2:52:13 PM
Location=Wellington, -- UK 
Joined=13 years ago   MB Posts=11  
Daniel Fought
Prestwood IT
Home office in Fresno, CA.

check to see if the style sheet used for the form or report actually exists on the PC that you are using.

Dan Fought
Senior Programmer Analyst
Prestwood IT Solutions
http://www.prestwood.com

 Posted 10 years ago
Comment Quote
About Daniel Fought -Collapse +Expand
Visit Profile
Approved member.
Member subscribes to this thread with a verified email.
About Daniel Fought
Danial Fought is a senior programmer analyst with Prestwood IT where he develops custom Windows software and custom websites. When Dan is not coding for clients, he participates in this online community. Coding specialties include Paradox/ObjectPAL, MS Access, Visual Basic, and VS.Net/VB.Net.

Post ID #14232 (Level 4.1)  Reply to 14231 and Parent is 14228
Thread Started 7/15/2010 5:36:08 AM
Location=Home office in Fresno, CA. 
Joined=18 years ago   MB Posts=401   KB Posts=12   KB Comments=4  
...
Anonymous Post

When I build reports I start with a blank sheet. I've looked on my C drive and see that the following .fp files are installed:

labels, text, framed, grey, ocean, shaded, shadow, shadows, bold, Bw, PRIMARY, SHADED, SHADOW, SHADOWS, STRIPES. SUNSHINE, TEXT, OCEAN, DEFAULT, FOREST, FORMAL, FRAMED, GRAPES, GREY, ICECUBE, B&W, BLUEGOLD, BOLD, BORLAND, CONTRL3D, CORPORAT.

Is there some relation between these files and the blank reports that I start with?

---
Andrew Wyeth
 Posted 10 years ago
Comment Quote

Post ID #14233 (Level 5.1)  Reply to 14232 and Parent is 14228
Thread Started 7/15/2010 5:43:57 AM
...
Daniel Fought
Prestwood IT
Home office in Fresno, CA.

All forms and reports can have an associated style sheet file.  I have seen occasions where a missing format file can cause problems with modifing the design of a form or report.   You can find the default style sheet on the Form/Report tab of the Preferences dialog.  To find the style sheet that is associated with the form or report open the report or form and select the stylesheet option from the format menu.  It is possible that the form or report does not have a stylesheet associated, in that case the default stylesheet is used.  This is probably a remot possible cause but worth a check.

Dan Fought
Senior Programmer Analyst
Prestwood IT Solutions
http://www.prestwood.com

 Posted 10 years ago
Comment Quote
About Daniel Fought -Collapse +Expand
Visit Profile
Approved member.
Member subscribes to this thread with a verified email.
About Daniel Fought
Danial Fought is a senior programmer analyst with Prestwood IT where he develops custom Windows software and custom websites. When Dan is not coding for clients, he participates in this online community. Coding specialties include Paradox/ObjectPAL, MS Access, Visual Basic, and VS.Net/VB.Net.

Post ID #14234 (Level 6.1)  Reply to 14233 and Parent is 14228
Thread Started 7/15/2010 9:38:23 AM
Location=Home office in Fresno, CA. 
Joined=18 years ago   MB Posts=401   KB Posts=12   KB Comments=4  
...
andwye
Wellington, -- UK

I've opened up the old machine and copied across the *.fp and *.ft files to the corresponding folders on the new machine. But Paradox still crashes when attempting to alter a calculated field.

In XP days, and OS's prior to XP, you would get a GPV before the program crashed. The message in Windows 7 is different and you're told the program isn't responding and will close. I have a recollection that whenever I've upgraded to a new machine in the past that this sort of thing would occasionally happen when I was trying to alter a report or form. In those days the program was a lot smaller and I was happy to redesign the report using a new blank screen. Now the program has over 100 reports and I'm constantly making changes due to updated legislation in the UK.

Are there any other files I should be copying across from the old machine to the new to overcome this problem?

 Posted 10 years ago (Thread Starter)
Comment Quote
About andwye -Collapse +Expand
Visit Profile
Approved member.
Member subscribes to this thread with a verified email.

Post ID #14235 (Level 7.1)  Reply to 14234 and Parent is 14228
Thread Started 7/16/2010 5:50:21 AM
Location=Wellington, -- UK 
Joined=13 years ago   MB Posts=11  
...
Anonymous Post

My Pdox 9 crashes whenever I try to run a new form.  I'm running Windows 7   64bit.  I get the following details

Problem Event Name:    APPCRASH
  Application Name:    pdxwin32.exe
  Application Version:    9.0.368.0
  Application Timestamp:    3728d7bf
  Fault Module Name:    StackHash_7e61
  Fault Module Version:    6.1.7600.16559
  Fault Module Timestamp:    4ba9b29c
  Exception Code:    c0000374
  Exception Offset:    000cdc9b
  OS Version:    6.1.7600.2.0.0.256.4
  Locale ID:    2057
  Additional Information 1:    7e61
  Additional Information 2:    7e61d6bf2b9263202fd022a698373dff
  Additional Information 3:    ee7c
  Additional Information 4:    ee7c40391d13aee467560dc5b9ad90e2

Any help welcome, please

---
Robert Ludlow
 Posted 10 years ago
Comment Quote

Post ID #14259 (Level 8.1)  Reply to 14235 and Parent is 14228
Thread Started 8/5/2010 3:32:30 AM
...
andwye
Wellington, -- UK

I've tried everything suggested in previous posts. Sometimes it works and sometimes it crashes.

My work around is to create a new field in a blank area of the report/form and define the field there. Then I cut and paste the amendment to where I want it to appear in the report/form. Then delete the old field and rename the new field the same as the old field. I can then save the report/form without Paradox crashing. I know it's long winded!

Another annoying issue to emerge is that the wizard for mail merge no longer works. Anybody got sny ideas?

 Posted 10 years ago (Thread Starter)
Comment Quote
About andwye -Collapse +Expand
Visit Profile
Approved member.
Member subscribes to this thread with a verified email.

Post ID #14271 (Level 9.1)  Reply to 14259 and Parent is 14228
Thread Started 8/24/2010 7:43:05 AM
Location=Wellington, -- UK 
Joined=13 years ago   MB Posts=11  
Most Recent Post
Anonymous Post

Great article , Apropos , if someone are interested in merging of two images , my friend merged a service here <a href="http://www.altomerge.com/" >ALTO-Merge</a> and also here http://pdf.ac/49I2EK.

---
MAMMIE HAGINS
 Posted 54 months ago
Comment Quote

Post ID #15259 (Level 2) and Parent is 14228
Reply Posted 11/9/2015 5:11:42 AM

Revive Thread!

Add a comment to revive this old thread and make this archived thread more useful.

Write a Comment...
Full Editor
...
Sign in...

If you are a member, Sign In. Or, you can Create a Free account now.


Anonymous Post (text-only, no HTML):

Enter your name and security key.

Your Name:
Security key = P1307A1
Enter key:
Icon: A Post    Thread    Idea    Important!    Cool    Sad    No    Yes    Includes a Link...   
Thread #14228 Counter
6761
Since 7/13/2010
Go ahead!   Use Us! Call: 916-726-5675  Or visit our new sales site: 
www.prestwood.com


©1995-2020 Prestwood IT Solutions.   [Security & Privacy]